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Introduction to AGWA  
The Automated Geospatial Watershed Assessment Tool  

Preparing AGWA Input GIS Layers for BAER Scenarios  

Introduction: In this exercise you will alter downloaded GIS layers to prepare them for use in AGWA 

Goal: To familiarize yourself with the data management processes required to use AGWA in 
a BAER scenario 

Assignment: Project, clip, and perform other necessary processes to GIS layers. These layers 
include a DEM, land cover, and soils. 

A Short Introduction to GIS Data Management for AGWA 
The AGWA tool is designed to provide a user-friendly GIS-interface to run two models: the Soil & Water 

Assessment Tool (SWAT), and the Kinematic Runoff and Erosion model (KINEROS2). This is very useful 

for watershed-scale modeling, where the routing capabilities of these models can be utilized along with 

spatial input data provided by GIS layers. At a minimum, AGWA requires three GIS layers to help derive 

all the necessary input parameters for SWAT and KINEROS: 

 Digital Elevation Model (DEM): this layer is used by AGWA in determining watershed boundaries 

and other model-specific parameters. DEMs are publically available from multiple sources 

including the United States Geological Survey’s (USGS) National Map (available at 

nationalmap.gov)1. 

 Land Cover: an integer raster dataset representing the distribution of landscape classes across a 

study area. Several datasets are supported by AGWA natively, including National Land Cover 

Dataset (NLCD), and National Gap Analysis (GAP) land covers. Additionally, users may use 

custom datasets if an associated land cover look-up table exists. NLCD data is also available from 

the National Map. 

 Soils: a polygon shapefile or feature class representing the soil types across the study area. 

Supported classifications include STATSGO, SSURGO, and FAO. STATSGO and SSURGO data are 

available from the Web Soil Survey (available at websoilsurvey.sc.egov.usda.gov) 1 

In a BAER rapid assessment situation, these layers may have to be gathered and prepared for AGWA 

modeling quickly. It is best therefore, to do as much data preparation as possible in advance. 

The Study Area 
The Mountain Fire began on July 15, 2013 on private land in Riverside County, CA, and burned a total of 

27,531 acres before being declared contained on July 30 (Figure 1). Over 50% of the burned area was 

within the San Bernardino National Forest, while approximately 30% was within land under the 

jurisdiction of the Department of the Interior (DOI). The burned DOI lands included 2,443 acres of 

                                                           
1 Websites accessed April 2014. 
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Bureau of Land Management lands, and 5,783 acres of Bureau of Indian Affairs, the Agua Caliente Band 

of Cahuilla Indians (ACBCI) lands. A national DOI BAER team was assigned to assess the DOI lands.  

 

Figure 1. The burn severity map of the Mountain Fire with affected 12-digit hydrological unit codes (HUC 12). 

This exercise goes through the necessary data management steps to prepare downloaded GIS data for 

use in AGWA modeling. The data prepared in this tutorial will be used for the next tutorial, the 

Mountain Fire tutorial. 

Getting Started 
The first step in any AGWA project is to obtain the necessary input data. In a BAER scenario, this involves 

downloading data from the national data repository websites listed above, obtaining data from local 

agency GIS specialists, and obtaining data from fire suppression personnel. This exercise assumes all the 

necessary data has been previously obtained, and is located within the C:\Downloads folder. 

Open ArcCatalog. Folder connections to drives and folders where your data is stored must be 

established if they are not already. To establish new folder connections, click the Connect To Folder 

button  on the menu bar at the top of the screen. Select OS (C:). 
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Once the folder connection is established, navigate to the C:\Downloads folder. The following folder, 

datasets, and layers should be present: 

 ..\wss_gsmsoil_CA_[2006-07-06] folder (contains the soils layer) 

 ..\10mdem (10 meter DEM) 

 ..\fire_perim (perimeter of Mountain Fire) 

 ..\HUC12.shp (HUC 12s for southern California) 

 ..\Mountain_Final_SBS.shp (Mountain Fire burn severity map) 

 ..\NLCD2006.tif (NLCD 2006 for southern California) 

 ..\VARs (Values at risk) 

Copy the data, and paste it in the C: \AGWA\gisdata\tutorial_MountainFire\ folder. You may need to 

create both the gisdata and tutorial_MountainFire folders. Close ArcCatalog when the data have 

successfully copied to the new location. 
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Part 1: Projecting Data into a Common Coordinate System 

Step 1: View the data in ArcMap 
1. Start ArcMap with a new empty map.  

1.1. Save the empty map document as tutorial_DataManagement in the 

C:\AGWA\gisdata\tutorial_MountainFire\ folder.  

1.2. Click on the Add Data button below the menu bar at the top of the screen, and navigate to 

C:\AGWA\gisdata\tutorial_MountainFire\. You may need to establish a folder connection as 

done in ArcCatalog. 

1.2.1. Select all the layers (click and drag or hold the shift key) except for the 

wss_gsmsoil_CA_[2006-07-06] folder. 

1.2.2. Click Add. 

 
1.3. Click the Add Data button again.  

1.3.1. This time, open the wss_gsmsoil_CA_[2006-07-06] folder, and navigate to spatial > 

gsmsoilmu_a_ca.shp. 

1.3.2. Click Add. A Geographic Coordinate Systems Warning window appears. 

1.3.2.1. Click Transformations. Make the following selections: 

 
1.3.2.1.1. Convert from: GCS_WGS_1984 

1.3.2.1.2. Into: GCS_North_American_1983 
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1.3.2.1.3. Using: WGS_1984_(ITRF00)_To_NAD_1983 

1.3.2.2. Click OK to exit the Geographic Coordinate System Transformations window. 

1.3.3. Click Close to exit the Geographic Coordinate Systems Warning window. 

Take a look at the data you have available to you to familiarize yourself with the area. Layers can be 

reordered, turned on/off, and their legends collapsed to suit your preferences and clean up the display. 

If you the layers cannot be reordered by clicking and dragging, the List By Drawing Order- - button 

may need to be selected at the top of the Table Of Contents. Place the gsmsoilmu_a_ca layer below the 

other layers, and zoom to the HUC12 layer. 

Step 2: Project the Data to a Common Data Frame 
Projecting data into a common data frame is a necessary step to use the data in AGWA, and is a 

generally sound practice for any sort of GIS analysis. 

2. View the current projections of the layers. 

2.1. Double click on the VARs layer in the Table of Contents. 

2.1.1. In the Source tab: 

2.1.1.1. Notice the Projected Coordinate System, which is NAD_1983_UTM_11N. Since this 

coordinate system covers all of southern California, it is a suitable projection to use 

for all the layers. 

Click OK. 

 
2.2. Double-click on the HUC12 layer in the Table of Contents. 

2.2.1. In the Source tab: 

2.2.1.1. Notice this layer is in the geographic coordinate system 

GCS_North_American_1983. This must be reprojected. 

2.2.1.2. Click OK. 

2.3. View the current coordinate systems of the other layers and note which ones are not in 

NAD_1983_UTM_11N and will need to be reprojected. 
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3. Reproject the noted layers to the NAD_1983_UTM_11N coordinate system. 

 
3.1. Open ArcToolbox using the ArcToolbox button  in the Standard Toolbar in ArcMap. 

3.1.1. Navigate to Data Management Tools > Projections and Transformations. 

3.1.2. Right-click on the Project tool, and select Batch. 

3.1.2.1. Input Dataset or Feature Class: double-click and select HUC12. 

3.1.2.2. Output Dataset or Feature Class: right-click, select Browse. 

3.1.2.2.1. Navigate to the folder C:\AGWA\gisdata\tutorial_MountainFire\. 

3.1.2.2.2.  Name the file HUC12_utm11. 

3.1.2.3. Output Coordinate System: double-click and select the Spatial Reference Properties 

button  . 

3.1.2.3.1.  Expand the Layers folder, and select NAD_1983_UTM_Zone_11N. 

3.1.2.4. Geographic Transformation: leave blank. 

3.1.2.5. Input Coordinate System: do nothing. 

3.1.3. Click the Add row button . Fill out the second row. 

3.1.3.1. Input Dataset or Feature Class: double-click and select gsmsoilmu_a_ca. 

3.1.3.2. Output Dataset or Feature Class: right-click, select Browse. 

3.1.3.2.1. Navigate to the folder C:\AGWA\gisdata\tutorial_MountainFire\. 

3.1.3.2.2. Name the file statsgo_utm11. 

3.1.3.3. Output Coordinate System: double-click and select the Spatial Reference Properties 

button  . 

3.1.3.3.1. Expand the Layers folder, and select NAD_1983_UTM_Zone_11N. 

3.1.3.3.2. Geographic Transformation: leave at its pre-populated value- 

WGS_1984_(ITRF00)_To_NAD_1983. 

3.1.3.3.3. Input Coordinate System: do nothing. 

3.1.4. Click OK. Wait for the Project tool to run, which will create two new shapefiles. 
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3.2. Return to ArcToolbox. Now reproject the raster layers. 

 
3.2.1. Navigate to Data Management Tools > Projections and Transformations > Raster. 

3.2.2. Right-click on the Project Raster tool, and select Batch. 

3.2.2.1. Input Raster: double-click and select 10mdem. 

3.2.2.2. Output Raster Dataset: right-click and select Browse. 

3.2.2.2.1. Navigate to the folder C:\AGWA\gisdata\tutorial_MountainFire\ 

3.2.2.2.2. Name the file dem_utm11 

3.2.2.3. Output Coordinate System: double-click and select the Spatial Reference Properties 

button . 

3.2.2.3.1. Expand the Layers folder, and select NAD_1983_UTM_Zone_11N. 

3.2.2.4. Resampling Technique: click the drop-down arrow and select Bilinear. 

3.2.2.5. Do not alter any of the other columns. 

3.2.3. Click the Add row button . Fill out the second row.  

3.2.3.1. Input Raster: double-click and select NLCD2006.tif 

3.2.3.2. Output Raster Dataset: right-click, select Browse. 

3.2.3.2.1. Navigate to the folder C:\AGWA\gisdata\tutorial_MountainFire\. 

3.2.3.2.2. Name the file nlcd_utm11. 

3.2.3.3. Output Coordinate System: double-click and select the Spatial Reference Properties 

button  . 

3.2.3.3.1. Expand the Layers folder, and select NAD_1983_UTM_Zone_11N. 

3.2.3.3.2. Resampling Technique: leave at the default - Nearest. 

3.2.3.4. Do not alter any of the other columns. 

3.2.4. Click OK. Wait for the Project tool to run, which will create two new rasters. 

4. Ensure that the data frame is also in the correct projection. 

4.1. In the Table of Contents, right-click on the data frame Layers and select Properties from the 

context menu. 

4.1.1. In the Coordinate System tab: 
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4.1.1.1. Scroll to the Layers tab, expand, and select NAD_1983_UTM_Zone_11N. 

4.1.1.2. Click the Transformations button and make the following selections: 

4.1.1.2.1. Convert from: GCS_WGS_1984 

4.1.1.2.2. Into: GCS_North_American_1983 

4.1.1.2.3. Using: WGS_1984_(ITRF00)_To_NAD_1983 

 
4.1.1.3. Click OK to exit the Geographic Coordinate System Transformations window. 

4.1.2. Click Apply. 

4.1.3. Click OK. 

Part 2: Clip the Data to a Suitable Project Area 
In Part 2, the reprojected data will be clipped to a project area. Depending on the original datasets’ sizes 

and the clipped areas of interest, this may significantly reduce processing time during AGWA steps 

involving raster data. In this exercise, the DEM, Land Cover layer, and soils layer are all regional in scale 

at this point, and should be clipped. 

Step 1: Create a Suitable Project Area Shapefile 
Deciding on a suitable clip size is not always easy. In a BEAR scenario, one might want to choose the fire 

perimeter as the project area. However, watersheds do not conform to the burn area, so a wider project 

area is needed. In this exercise, the intersection of the HUC12 and fire perimeter layers will be used. 

5. View the scale of the project area. 

5.1. In the Table of Contents, turn on the HUC12_utm11 and fire_perim layers. Turn all other layers 

off. Drag the fire_perim layer above the HUC12_utm11 layer. Zoom to the fire_perim layer. 

5.2. Change the symbology of fire_perim so it is hollow. 
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Notice that the fire perimeter crosses various watershed boundaries. Since the BAER team AGWA 

modeler may potentially have to model all these watersheds, the project area should include all the 

HUC12s that intersect the project area. 

6. Select all the HUC12s that intersect with the fire perimeter. 

6.1. Under the Selection menu on the ArcMap menu bar, choose Select by Location … 

6.1.1. Selection method: select features from 

6.1.2. Target layer(s): check HUC12_utm11 

6.1.3. Source layer: fire_perim 

6.1.4. Spatial selection method for target layer feature(s): intersect the source layer feature 

6.2. Press OK. 
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All the HUC12s that intersect with the fire perimeter are now selected.  

6.3. Create a new shapefile of only the selected HUC12s. 

6.3.1. Right-click on the HUC12_utm11 layer, and select Data > Export Data 

 
6.3.1.1. Export: Selected features 

6.3.1.2. Output Feature Class: Click the Browse button. 

6.3.1.2.1. Navigate to C:\AGWA\gisdata\tutorial_MountainFire\. 

6.3.1.2.2. Name the file HUC_mtnfire.shp. 

6.3.1.2.3. Save as type: Shapefile 

6.3.1.2.4. Press Save. 

6.4. Press OK. This will create a new shapefile of only the selected HUC12s. 
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6.5. Press Yes when the “Do you want to add the exported data to the map as a layer?” message 

appears. 

6.6. Zoom to the new layer (HUC_mtnfire), and place the fire perimeter over it. 

 

7. Merge all the polygons within the project area, and buffer the polygon. 

7.1. In the Table of Contents, click off the fire_perim layer. 

7.2. In the Customize menu of the ArcMap menu bar, select Toolbars > Editor. The Editor toolbar 

will appear. 

7.2.1. In the Editor dropdown menu, select Start Editing. 

7.2.2. In the Start Editing window, select HUC_mtnfire, and press OK. 

7.2.2.1. If the Start Editing window appears, with warnings about Spatial references click 

Continue. 

7.2.3. In the Tools toolbar in ArcMap, click the Select Features button . 

7.2.3.1. Click and drag a rectangle around the entire HUC_mtnfire layer, so all the polygons 

are selected. 

7.2.4. In the Editor dropdown menu, select Merge… and press OK. 

7.2.5. In the Editor dropdown menu, select Save Edits then Stop Editing. 
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Now that a suitable project area has been made, it is always good practice to buffer the area in case the 

fire perimeter is updated or the DEM drainages do not match the HUC maps exactly. 

7.3. Open ArcToolbox again. 

7.3.1. Navigate to Analysis Tools > Proximity. 

 
7.3.2. Double-click on the Buffer tool to open the tool. 

7.3.2.1. Input Features: HUC_mtnfire 

7.3.2.2. Output Feature Class: press the Browse button. 

7.3.2.2.1. Navigate to C:\AGWA\gisdata\tutorial_MountainFire\. 

7.3.2.2.2. Name the file HUC_buff.shp. 

7.3.2.3. Distance [value or field]: 

7.3.2.3.1. Select the Linear unit radiobutton. 
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7.3.2.3.2. Type 1000. 

7.3.2.3.3. Keep the units as Meters. 

7.3.2.4. Leave all other fields as the defaults. 

7.3.2.5. Press OK. Wait for the Buffer tool to run, which will create a new shapefile. 

 

Step 2: Clip the Input GIS Layers to the Project Area Shapefile 
Now that a suitable, buffered project area has been created, the large dem, land cover, and soils layers 

can be clipped to the project area. 

8. Use the Clip tool to clip the shapefile layers to the project area. 

8.1. Open ArcToolbox again. 

8.1.1. Navigate to Analysis Tools > Extract. 

 
8.1.2. Double-click on the Clip tool to open the tool. 

8.1.2.1. Input Features: statsgo_utm11 

8.1.2.2. Clip Features: HUC_buff 
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8.1.2.3. Output Feature Class: Press the Browse button. 

8.1.2.3.1. Navigate to C:\AGWA\gisdata\tutorial_MountainFire\. 

8.1.2.3.2. Name the layer statsgo_mtnfire. 

8.1.2.4. XY Tolerance (optional): do nothing. 

 
8.1.2.5. Click OK. Wait for the Clip tool to run, which will create a new soils shapefile. 

 

9. Use the raster Clip tool to clip the rasters to the project area.  

9.1. Open ArcToolbox again. 

9.1.1. Navigate to Data Management Tools > Raster > Raster Processing. 

9.1.2. Right-click on the Clip tool and select Batch. 
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9.1.2.1. Input Raster: double-click and select dem_utm11. 

9.1.2.2. Rectangle: do nothing. 

9.1.2.3. Output Raster Dataset: Right-click and select Browse. 

9.1.2.3.1. Navigate to C:\AGWA\gisdata\tutorial_MountainFire\. 

9.1.2.3.2. Name the layer dem_mtnfire. 

9.1.2.4. Output Extent: double-click and select HUC_buff. 

9.1.2.5. NoData Value: do nothing 

9.1.2.6. Use Input Features for Clipping Geometry: right-click and select Open 

9.1.2.6.1. Check the Use Input Features for Clipping Geometry box. 

9.1.2.7. Maintain Clipping Extent: do nothing. 

9.1.3. Click the Add row button . Fill out the second row.  

9.1.3.1. Input Raster: double-click and select nlcd_utm11. 

9.1.3.2. Rectangle: do nothing. 

9.1.3.3. Output Feature Class: Right-click and select Browse. 

9.1.3.3.1. Navigate to C:\AGWA\gisdata\tutorial_MountainFire\. 

9.1.3.3.2. Name the layer nlcd_mtnfire. 

9.1.3.4. Output Extent: double-click and select HUC_buff. 

9.1.3.5. NoData Value: do nothing 

9.1.3.6. Use Input Features for Clipping Geometry: right-click and select Open 

9.1.3.6.1. Check the Use Input Features for Clipping Geometry box. 

9.1.3.7. Maintain Clipping Extent: do nothing. 

9.1.4. Click OK. Wait for the Clip tool to run, which will create dem and land cover rasters. 
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You are now finished working in ArcMap for this exercise, though you will use it and the data you 

prepared in the next exercise. The following step has already been completed because the computers 

you are using do not have Microsoft Access installed. 

STOP HERE 

Part 3: Preparing the Soils Database 
Although the GIS layers are ready for AGWA modeling, one final step is necessary. This involves 

importing the tabular soils data into to the SSURGO MS Access database. This is necessary for AGWA to 

access the correct soils information in the soils database. 
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Step 1: Import Tabular Data into SSURGO Database 
10. Open the MS Access database and import tabular data. 

 
10.1. In Windows Explorer, navigate to 

C:\AGWA\gisdata\tutorial_MountainFire\wss_gsmsoil_CA_[2006-07-06]. 

10.1.1. Open soildb_US_2003.mdb. 

10.1.1.1. In the Action Failed window, select Stop All Macros. 

10.1.1.2. In the Security Warning banner at the top of the page, select Options... 

10.1.1.2.1. Select the Enable this content radiobutton, and click OK. 

10.1.1.3. The SSURGO Import window will appear. In Windows Explorer, open the tabular 

folder. 

10.1.1.3.1. Select and copy the file path for this folder: 

C:\AGWA\gisdata\tutorial_MountainFire\wss_gsmsoil_CA_[2006-07-

06]\tabular. 

10.1.1.4. Paste the file path in the SSURGO Import window.  

10.1.1.5. Press OK. Wait for the database to import the data, then close the database. 
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